Advanced search

Message boards : Server and website : "Client Detached" Issue...

Author Message
Profile WirelessDude
Send message
Joined: 3 Aug 11
Posts: 21
Credit: 189,614,059
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwat
Message 22330 - Posted: 22 Oct 2011 | 6:48:08 UTC

At 22 Oct 2011 5:15:25 UTC, the client on my ARNIE-PCH machine did a "client detached" on 28 consecutive WU's before downloading some WU's that are now being processed normally.

What would cause this?

WirelessDude

MarkJ
Volunteer moderator
Project tester
Volunteer tester
Send message
Joined: 24 Dec 08
Posts: 738
Credit: 200,666,904
RAC: 0
Level
Leu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22331 - Posted: 22 Oct 2011 | 6:58:16 UTC - in response to Message 22330.

At 22 Oct 2011 5:15:25 UTC, the client on my ARNIE-PCH machine did a "client detached" on 28 consecutive WU's before downloading some WU's that are now being processed normally.

What would cause this?

WirelessDude


Do you use an account manager (eg BAM or GridRepublic)? If you have manually attached it will detach you. You need to attach using the account manager.
____________
BOINC blog

Profile WirelessDude
Send message
Joined: 3 Aug 11
Posts: 21
Credit: 189,614,059
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwat
Message 22332 - Posted: 22 Oct 2011 | 7:07:43 UTC

Nope... I have always been using the BOINC Manager to do the project additions.

WirelessDude

Profile skgiven
Volunteer moderator
Project tester
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22334 - Posted: 22 Oct 2011 | 11:18:16 UTC - in response to Message 22332.

6.10.36 perhaps. Try 6.10.60 or 6.12.34

Profile WirelessDude
Send message
Joined: 3 Aug 11
Posts: 21
Credit: 189,614,059
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwat
Message 22339 - Posted: 22 Oct 2011 | 20:48:49 UTC - in response to Message 22334.

Running 6.12.34 on all three active clients...

WirelessDude

MarkJ
Volunteer moderator
Project tester
Volunteer tester
Send message
Joined: 24 Dec 08
Posts: 738
Credit: 200,666,904
RAC: 0
Level
Leu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22340 - Posted: 22 Oct 2011 | 21:30:45 UTC - in response to Message 22339.

Running 6.12.34 on all three active clients...

WirelessDude


In the "event log" (formerly known as the messages tab) what does it have in the startup messages about project prefs?
____________
BOINC blog

Profile WirelessDude
Send message
Joined: 3 Aug 11
Posts: 21
Credit: 189,614,059
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwat
Message 22341 - Posted: 22 Oct 2011 | 22:48:53 UTC - in response to Message 22340.

I don't see anything out of the ordinary on the prefs. I am about to dismiss the issue as a fluke since it hasn't happened again (yet...) Here is an excerpt of my log around the time the client detached:

...
10/21/2011 10:38:02 PM | GPUGRID | Sending scheduler request: To fetch work.
10/21/2011 10:38:02 PM | GPUGRID | Requesting new tasks for NVIDIA GPU
10/21/2011 10:38:07 PM | GPUGRID | Scheduler request completed: got 0 new tasks
10/21/2011 10:38:07 PM | GPUGRID | Result 83-IBUCH_PYRT_111019-1-10-RND7851_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result I63R0-GIANNI_KKFREE5-52-100-RND9456_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result 32-IBUCH_freePYRT_111020-0-10-RND4229_2 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result 522-IBUCH_PYRT_111019-1-10-RND4236_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result s0r393-TONI_SH2MS3-57-100-RND6056_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result s0r158-TONI_SH2MS3-45-100-RND4180_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result p48-IBUCH_3_nmEGFR_111011-9-20-RND3157_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result 395-IBUCH_PYRT_111019-1-10-RND5502_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result s0r342-TONI_SH2MS3-57-100-RND3357_1 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result I139R3-GIANNI_KKFREE5-43-100-RND3305_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result s0r238-TONI_SH2MS3-62-100-RND2762_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result p2-IBUCH_5_cmEGFR_110914-19-20-RND1450_2 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result I164R3-GIANNI_KKFREE5-50-100-RND4133_2 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result s0r441-TONI_SH2MS3-55-100-RND1261_1 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result I26R1-GIANNI_KKFREE5-45-100-RND0446_0 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | Result I182R1-GIANNI_KKFREE5-44-100-RND7859_1 is no longer usable
10/21/2011 10:38:07 PM | GPUGRID | No work sent
10/21/2011 10:38:07 PM | GPUGRID | No work is available for Long runs (8-12 hours on fastest card)
10/21/2011 10:38:07 PM | GPUGRID | (reached limit of 16 GPU tasks in progress)
10/21/2011 10:38:07 PM | GPUGRID | Project has no jobs available
10/21/2011 10:38:08 PM | GPUGRID | Computation for task 83-IBUCH_PYRT_111019-1-10-RND7851_0 finished
10/21/2011 10:38:08 PM | GPUGRID | Computation for task I63R0-GIANNI_KKFREE5-52-100-RND9456_0 finished
10/21/2011 10:38:08 PM | GPUGRID | Computation for task 32-IBUCH_freePYRT_111020-0-10-RND4229_2 finished
10/21/2011 10:38:08 PM | GPUGRID | Computation for task 522-IBUCH_PYRT_111019-1-10-RND4236_0 finished
10/21/2011 10:38:08 PM | GPUGRID | Computation for task s0r393-TONI_SH2MS3-57-100-RND6056_0 finished
10/21/2011 10:38:08 PM | GPUGRID | Computation for task s0r158-TONI_SH2MS3-45-100-RND4180_0 finished
10/21/2011 10:38:08 PM | GPUGRID | Computation for task p48-IBUCH_3_nmEGFR_111011-9-20-RND3157_0 finished
10/21/2011 10:38:08 PM | GPUGRID | Computation for task 395-IBUCH_PYRT_111019-1-10-RND5502_0 finished
10/21/2011 10:39:39 PM | GPUGRID | Sending scheduler request: To report completed tasks.
10/21/2011 10:39:39 PM | GPUGRID | Reporting 16 completed tasks, requesting new tasks for NVIDIA GPU
10/21/2011 10:39:45 PM | GPUGRID | Scheduler request completed: got 11 new tasks
10/21/2011 10:39:47 PM | GPUGRID | Started download of p47-IBUCH_1_nmEGFR_111011-9-LICENSE
10/21/2011 10:39:47 PM | GPUGRID | Started download of p47-IBUCH_1_nmEGFR_111011-9-COPYRIGHT
10/21/2011 10:39:50 PM | GPUGRID | Finished download of p47-IBUCH_1_nmEGFR_111011-9-LICENSE
10/21/2011 10:39:50 PM | GPUGRID | Finished download of p47-IBUCH_1_nmEGFR_111011-9-COPYRIGHT
10/21/2011 10:39:50 PM | GPUGRID | Started download of p47-IBUCH_1_nmEGFR_111011-9-p47-IBUCH_1_nmEGFR_111011-8-20-RND9407_1
10/21/2011 10:39:50 PM | GPUGRID | Started download of p47-IBUCH_1_nmEGFR_111011-9-p47-IBUCH_1_nmEGFR_111011-8-20-RND9407_2
...

WirelessDude

MarkJ
Volunteer moderator
Project tester
Volunteer tester
Send message
Joined: 24 Dec 08
Posts: 738
Credit: 200,666,904
RAC: 0
Level
Leu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22347 - Posted: 23 Oct 2011 | 3:49:44 UTC - in response to Message 22341.
Last modified: 23 Oct 2011 | 3:51:19 UTC

I don't see anything out of the ordinary on the prefs. I am about to dismiss the issue as a fluke since it hasn't happened again (yet...) Here is an excerpt of my log around the time the client detached:

...
<snipped>
...

WirelessDude


Not those messages. Ones like these at BOINC startup, just after the NVIDIA GPU lines.

18 climateprediction.net 17-10-2011 10:26 PM URL http://climateprediction.net/; Computer ID 1234; resource share 25
19 Einstein@Home 17-10-2011 10:26 PM URL http://einstein.phys.uwm.edu/; Computer ID 5678; resource share 25
20 GPUGRID 17-10-2011 10:26 PM URL http://www.gpugrid.net/; Computer ID 51761; resource share 50
21 17-10-2011 10:26 PM General prefs: from http://setiathome.berkeley.edu/ (last modified 27-Mar-2011 21:30:55)
22 17-10-2011 10:26 PM Computer location: home
23 17-10-2011 10:26 PM General prefs: no separate prefs for home; using your defaults

____________
BOINC blog

Operator
Send message
Joined: 15 May 11
Posts: 108
Credit: 297,176,099
RAC: 0
Level
Asn
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22618 - Posted: 29 Nov 2011 | 19:03:43 UTC - in response to Message 22347.

I've had this happen to me twice, most recently last night.

Four WUs were in progress and a three were "Ready to Start' with another downloading. One of these was a 97% complete.

I left the room for 10 minutes, came back and all the units in work had disappeared as well as all the "Ready to start" units, and the task tab showed 8 units downloading.

There was nothing in the event log to indicate what had happened. The first time this happened about 3-4 weeks ago there was something about 'client detached', but not last night.

Some of the work units were;

http://www.gpugrid.net/workunit.php?wuid=2894643
http://www.gpugrid.net/workunit.php?wuid=2894642
http://www.gpugrid.net/workunit.php?wuid=2894345

It's frustrating because there's no smoking gun.

Operator

Post to thread

Message boards : Server and website : "Client Detached" Issue...