Advanced search

Message boards : Graphics cards (GPUs) : Only 4GB of memory seen for Titan Black

Author Message
jlhal
Send message
Joined: 1 Mar 10
Posts: 147
Credit: 1,077,535,540
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 39069 - Posted: 4 Dec 2014 | 22:06:49 UTC
Last modified: 4 Dec 2014 | 22:15:05 UTC

Hi,
I run Lubuntu 14.04 LTS x86_64
In Gpugrid (Boinc 7.4.23) see that, whatever driver is used, only 4095MB available memory is reported for the Titan Black instead of 6GB.

For OpenGl the size is correctly reported as 6GB
Nvidia X server reports also correctly the 6GB.

Is it a limitation ?

Thanks for your time
____________
Lubuntu 16.04.1 LTS x64

Profile MJH
Project administrator
Project developer
Project scientist
Send message
Joined: 12 Nov 07
Posts: 696
Credit: 27,266,655
RAC: 0
Level
Val
Scientific publications
watwat
Message 39070 - Posted: 5 Dec 2014 | 0:07:42 UTC - in response to Message 39069.

Don't worry about it, it's just being misreported.

None of our WUs need that much memory anyhow.

jlhal
Send message
Joined: 1 Mar 10
Posts: 147
Credit: 1,077,535,540
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 39075 - Posted: 5 Dec 2014 | 12:10:15 UTC - in response to Message 39070.

Don't worry about it, it's just being misreported.

I did not worry, may be this could just hide some misbehaviour ;-)

None of our WUs need that much memory anyhow.
I know, they need less than 900MB at the moment and use between 75% and 93% of the GPU power


____________
Lubuntu 16.04.1 LTS x64

Wrend
Send message
Joined: 9 Nov 12
Posts: 50
Credit: 506,337,784
RAC: 0
Level
Lys
Scientific publications
watwatwatwatwatwat
Message 39206 - Posted: 18 Dec 2014 | 22:46:27 UTC

I'm not sure what causes this video card memory misreporting. It isn't just an issue with BOINC either. The memory is there though (of course) and can be fully utilized, if needed.

If you have some GPU monitoring software such as the one in the EVGA OC Scanner X, it will correctly show the memory load and availability.

I have two EVGA Titan Black Superclocked cards in SLI (so the memory is mirrored between them) for gaming, but also run two GPUGrid long run work units per GPU. This means their memory is loaded with four long run work units each. Even with that, I don't have any memory issues with these cards, regardless of the memory being misreported by some programs. The current memory load for the cards is at about 65%, 4004MB with just these work units running. (Current GPU loads are 93% for each GPU.)

Hope this helps.
____________
My BOINC Cruncher, Minecraft Multiserver, Mobile Device Mainframe, and Home Entertainment System/Workstation: http://www.overclock.net/lists/display/view/id/4678036#

Post to thread

Message boards : Graphics cards (GPUs) : Only 4GB of memory seen for Titan Black