Advanced search

Message boards : Graphics cards (GPUs) : GeForce GTX 850M + Intel HD4600 : no work from GPUGRID

Author Message
Julien
Send message
Joined: 17 Jan 14
Posts: 6
Credit: 482,010,075
RAC: 0
Level
Gln
Scientific publications
watwatwatwatwatwatwatwatwat
Message 38596 - Posted: 20 Oct 2014 | 23:29:44 UTC
Last modified: 20 Oct 2014 | 23:30:55 UTC

Hi everybody,

I'm now running GPUGRID since January, on a GTX 550 Ti Golden Sample.

With a new computer, which embeds a GTX 850M, I'm interested in doubling (in fact, a little bit more than doubling) the work done by my computer(s) on GPUGRID.

But into the event logs, I have :

21/10/2014 01:20:17 | GPUGRID | Sending scheduler request: To fetch work.
21/10/2014 01:20:17 | GPUGRID | Requesting new tasks for NVIDIA and intel_gpu
21/10/2014 01:20:18 | GPUGRID | Scheduler request completed: got 0 new tasks
21/10/2014 01:20:18 | GPUGRID | No tasks sent

Do you know what I have to do in order to get it working ?
Some of you will probably say "turn off the HD4600 from bios" but I think it's a little bit rude, is there something more specific to do ?

Thank you in advance !

eXaPower
Send message
Joined: 25 Sep 13
Posts: 280
Credit: 1,449,568,667
RAC: 89
Level
Met
Scientific publications
watwatwatwatwatwatwatwat
Message 38597 - Posted: 20 Oct 2014 | 23:59:45 UTC
Last modified: 21 Oct 2014 | 0:03:14 UTC

http://www.gpugrid.net/forum_thread.php?id=3733

http://www.gpugrid.net/forum_thread.php?id=3874

You're GTX850m is a Compute Capability 5.0 card. The driver installed on you're machine will only receive CUDA4.2 tasks. Update driver to receive CUDA6.5 tasks. There are less CUDA 4.2 tasks available than CUDA6.0 or 6.5 tasks due to the small percentage of cards computing CUDA4.2.


http://www.gpugrid.net/graphs/

Julien
Send message
Joined: 17 Jan 14
Posts: 6
Credit: 482,010,075
RAC: 0
Level
Gln
Scientific publications
watwatwatwatwatwatwatwatwat
Message 38599 - Posted: 21 Oct 2014 | 1:42:53 UTC
Last modified: 21 Oct 2014 | 2:00:28 UTC

Thank you for your answer. It explains why Asteroids for example, is working.

So I will have to find a way to put a new driver (or wait for it) because apparently, the new driver is not for me !

This laptop is on 333.02, GeForce Experience saying "Up to date"

And when on www.nvidia.com I choose a GTX 800M séries (Laptop), GTX 850M, for Win 8.1 (64 bits), it gives me a driver (344.11) that is, apparently, not suitable for this card (when I try to install it, it says that there is no device that suits this driver).

http://imageshack.com/a/img674/4269/aTWqBS.png
http://imageshack.com/a/img673/3644/eEhDx6.png
http://imageshack.com/a/img673/2383/ztQqPU.png


I will stay tunned for updates ! And try to understand why my GeForce is so different, and may be, one day, accept his difference. :p

Thank you for youy answer, bye !


EDIT :

With the "A2" revision name, running at 1085 MHz, 28nm, it's like this GTX 850M is, in fact, a GTX 750Ti...

http://www.techpowerup.com/gpudb/2538/geforce-gtx-850m.html
http://www.techpowerup.com/gpudb/2548/geforce-gtx-750-ti.html

But it doesn't explains why there is no driver update like for all the others ones.

May be Asus made something very strange here (the only driver I had working was the one on the Asus website. No driver available with Microsoft update, for a GeForce it's very strange.

PCI\VEN_10DE&DEV_1391&SUBSYS_178D1043&REV_A2

But don't worry I will try to find a way to fix it myself.

Julien
Send message
Joined: 17 Jan 14
Posts: 6
Credit: 482,010,075
RAC: 0
Level
Gln
Scientific publications
watwatwatwatwatwatwatwatwat
Message 38672 - Posted: 25 Oct 2014 | 2:17:17 UTC
Last modified: 25 Oct 2014 | 2:19:38 UTC

Done :) Now the 344.48 is for me !

It was because of things like PCI\VEN_10DE&DEV_1391&SUBSYS_178D1043&REV_A2
Some notebooks GPUs aren't recognized like they should be because of an (useless) ID difference with "standard" GTX 850M cards (Asus... touching everything that already works before they touch it)


This forum topic is collecting this kind of case in order to add support in the new drivers :

https://forums.geforce.com/default/topic/534575/geforce-drivers/official-nvidia-verde-notebook-gpu-driver-request-thread/32/

Now, it's running !
Thank you

ExtraTerrestrial Apes
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 17 Aug 08
Posts: 2688
Credit: 1,172,901,099
RAC: 176,610
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 38684 - Posted: 25 Oct 2014 | 22:27:29 UTC

It's good to hear you made it work! Updating drivers on a laptop can be a real pain. It's even more complicated since nVidia Optimus and the AMD equivalent. Even worse is that most vendors stop providing updates after about 1 year. So people have to resort to inf-mods to get things working.

MrS
____________
Scanning for our furry friends since Jan 2002

Post to thread

Message boards : Graphics cards (GPUs) : GeForce GTX 850M + Intel HD4600 : no work from GPUGRID