Advanced search

Message boards : Server and website : no tasks sent BOINC manager issue

Author Message
werdwerdus
Send message
Joined: 15 Apr 10
Posts: 123
Credit: 1,004,473,861
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 27256 - Posted: 9 Nov 2012 | 18:13:50 UTC

i3-3220-xp64

1125 GPUGRID 11/9/2012 12:08:53 PM Requesting new tasks for NVIDIA
1126 GPUGRID 11/9/2012 12:08:55 PM Scheduler request completed: got 0 new tasks
1127 GPUGRID 11/9/2012 12:08:55 PM No tasks sent
1128 GPUGRID 11/9/2012 12:08:55 PM No tasks are available for the applications you have selected.
1129 GPUGRID 11/9/2012 12:08:55 PM Tasks won't finish in time: BOINC runs 99.7%% of the time; computation is enabled 100.0%% of that

there are no tasks in queue or running.. sitting idle. I have 3 gpus on the system: 2 are ignored for GPUGrid and 1 is ignored for WCG. There are tasks running on the other 2 gpus for WCG. I have BOINC 7.0.36 running, thought the ignored GPUs would be accounted for in requesting tasks. Any ideas?
____________
XtremeSystems.org - #1 Team in GPUGrid

MarkJ
Volunteer moderator
Project tester
Volunteer tester
Send message
Joined: 24 Dec 08
Posts: 732
Credit: 197,194,445
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 27261 - Posted: 9 Nov 2012 | 20:35:39 UTC - in response to Message 27256.
Last modified: 9 Nov 2012 | 20:40:00 UTC

i3-3220-xp64

1125 GPUGRID 11/9/2012 12:08:53 PM Requesting new tasks for NVIDIA
1126 GPUGRID 11/9/2012 12:08:55 PM Scheduler request completed: got 0 new tasks
1127 GPUGRID 11/9/2012 12:08:55 PM No tasks sent
1128 GPUGRID 11/9/2012 12:08:55 PM No tasks are available for the applications you have selected.
1129 GPUGRID 11/9/2012 12:08:55 PM Tasks won't finish in time: BOINC runs 99.7%% of the time; computation is enabled 100.0%% of that

there are no tasks in queue or running.. sitting idle. I have 3 gpus on the system: 2 are ignored for GPUGrid and 1 is ignored for WCG. There are tasks running on the other 2 gpus for WCG. I have BOINC 7.0.36 running, thought the ignored GPUs would be accounted for in requesting tasks. Any ideas?


There was some discussion on the mailing list about the excluded GPUs and how they are being handled. 7.0.38 has a bit of a work-around but it had some windows installer issues.

What are your cache settings, tasks selected (in project prefs on the web site) and are you using an app_info? Running GPUgrid is best on a very low cache setting. It will give 2 work units per GPU at a maximum.
____________
BOINC blog

werdwerdus
Send message
Joined: 15 Apr 10
Posts: 123
Credit: 1,004,473,861
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 27263 - Posted: 10 Nov 2012 | 5:45:33 UTC
Last modified: 10 Nov 2012 | 5:47:06 UTC

got a task. lowered cache to 1 day min / 1 day max additional. I was at 8 days min cache trying to get enough WCG GPU tasks in order not to run dry there, since they are way over estimated in the time to complete.

now I have 6 tasks... even though 2 gpus are ignored for GPUGrid using cc_config.xml. I can't find any option to limit the number of tasks per device or per project.
____________
XtremeSystems.org - #1 Team in GPUGrid

MarkJ
Volunteer moderator
Project tester
Volunteer tester
Send message
Joined: 24 Dec 08
Posts: 732
Credit: 197,194,445
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 27264 - Posted: 10 Nov 2012 | 6:26:38 UTC - in response to Message 27263.

got a task. lowered cache to 1 day min / 1 day max additional. I was at 8 days min cache trying to get enough WCG GPU tasks in order not to run dry there, since they are way over estimated in the time to complete.

now I have 6 tasks... even though 2 gpus are ignored for GPUGrid using cc_config.xml. I can't find any option to limit the number of tasks per device or per project.


If you had 8 days before that's probably why you didn't get any work, GPUgrid has a 7day deadline. Even with your current settings you might struggle until your BOINC learns what the actual times are for each project.

I run my GPUgrid machines with a 0.01/0.1 cache settings using "network always available" which means they download a WU when they've just about finished the current one and report almost straight after the upload completes. This helps with the long WU which can run for up to 12 hours each depending on which ones you get.
____________
BOINC blog

mikey
Send message
Joined: 2 Jan 09
Posts: 278
Credit: 470,229,740
RAC: 209,260
Level
Gln
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 27266 - Posted: 10 Nov 2012 | 13:50:25 UTC - in response to Message 27263.
Last modified: 10 Nov 2012 | 13:51:08 UTC

got a task. lowered cache to 1 day min / 1 day max additional. I was at 8 days min cache trying to get enough WCG GPU tasks in order not to run dry there, since they are way over estimated in the time to complete.

now I have 6 tasks... even though 2 gpus are ignored for GPUGrid using cc_config.xml. I can't find any option to limit the number of tasks per device or per project.


You can only do that thru the cache settings, as far as I know, but can do it on a pc by pc basis if you use the Boinc Manager which is down by the clock. Be sure to click ok when you are done tweaking or the settings won't be saved.

werdwerdus
Send message
Joined: 15 Apr 10
Posts: 123
Credit: 1,004,473,861
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 27274 - Posted: 10 Nov 2012 | 20:16:57 UTC
Last modified: 10 Nov 2012 | 20:18:26 UTC

I use a 0.1/0.1 or 0.05/0.1 cache normally. Only reason for higher cache on this machine is I have 2 other GPUs working on WCG and I was running dry. I tried 0.01 cache before, but BOINC manager would run dry when one finished and waiting to download the next.
____________
XtremeSystems.org - #1 Team in GPUGrid

Jacob Klein
Send message
Joined: 11 Oct 08
Posts: 1115
Credit: 1,831,665,089
RAC: 312,617
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 27298 - Posted: 13 Nov 2012 | 18:30:29 UTC
Last modified: 13 Nov 2012 | 18:30:52 UTC

I am currently having a problem where BOINC requests tasks from GPUGrid.Net, but none are given. At first I thought it might be because my reported results from some previous work had a few errors, but according to my results (via http://www.gpugrid.net/results.php?userid=8048 )... the last reported error was 6 Nov 2012 | 13:22:26 UTC... which was exactly 1 week ago.

- Is there any way to further diagnose why I am not getting tasks?
- How long does the GPUGrid.net server usually "blacklist" a user or host for reporting bad results?
- Could they include a message to be shown in the BOINC Event Log, explaining WHY no tasks were given?

11/10/2012 12:30:08 AM | GPUGRID | Sending scheduler request: To fetch work.
11/10/2012 12:30:08 AM | GPUGRID | Requesting new tasks for NVIDIA
11/10/2012 12:30:10 AM | GPUGRID | Scheduler request completed: got 0 new tasks
11/10/2012 12:30:10 AM | GPUGRID | No tasks sent
.....
11/10/2012 7:26:58 PM | GPUGRID | Sending scheduler request: To fetch work.
11/10/2012 7:26:58 PM | GPUGRID | Requesting new tasks for NVIDIA
11/10/2012 7:27:00 PM | GPUGRID | Scheduler request completed: got 0 new tasks
11/10/2012 7:27:00 PM | GPUGRID | No tasks sent
.....
11/11/2012 2:08:53 PM | GPUGRID | Sending scheduler request: To fetch work.
11/11/2012 2:08:53 PM | GPUGRID | Requesting new tasks for NVIDIA
11/11/2012 2:08:55 PM | GPUGRID | Scheduler request completed: got 0 new tasks
11/11/2012 2:08:55 PM | GPUGRID | No tasks sent
.....
11/12/2012 9:19:50 AM | GPUGRID | Sending scheduler request: To fetch work.
11/12/2012 9:19:50 AM | GPUGRID | Requesting new tasks for NVIDIA
11/12/2012 9:19:52 AM | GPUGRID | Scheduler request completed: got 0 new tasks
11/12/2012 9:19:52 AM | GPUGRID | No tasks sent

MarkJ
Volunteer moderator
Project tester
Volunteer tester
Send message
Joined: 24 Dec 08
Posts: 732
Credit: 197,194,445
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 27300 - Posted: 14 Nov 2012 | 2:38:44 UTC - in response to Message 27298.

I am currently having a problem where BOINC requests tasks from GPUGrid.Net, but none are given. At first I thought it might be because my reported results from some previous work had a few errors, but according to my results (via http://www.gpugrid.net/results.php?userid=8048 )... the last reported error was 6 Nov 2012 | 13:22:26 UTC... which was exactly 1 week ago.

- Is there any way to further diagnose why I am not getting tasks?
- How long does the GPUGrid.net server usually "blacklist" a user or host for reporting bad results?
- Could they include a message to be shown in the BOINC Event Log, explaining WHY no tasks were given?

11/10/2012 12:30:08 AM | GPUGRID | Sending scheduler request: To fetch work.
11/10/2012 12:30:08 AM | GPUGRID | Requesting new tasks for NVIDIA
11/10/2012 12:30:10 AM | GPUGRID | Scheduler request completed: got 0 new tasks
11/10/2012 12:30:10 AM | GPUGRID | No tasks sent
.....
11/10/2012 7:26:58 PM | GPUGRID | Sending scheduler request: To fetch work.
11/10/2012 7:26:58 PM | GPUGRID | Requesting new tasks for NVIDIA
11/10/2012 7:27:00 PM | GPUGRID | Scheduler request completed: got 0 new tasks
11/10/2012 7:27:00 PM | GPUGRID | No tasks sent
.....
11/11/2012 2:08:53 PM | GPUGRID | Sending scheduler request: To fetch work.
11/11/2012 2:08:53 PM | GPUGRID | Requesting new tasks for NVIDIA
11/11/2012 2:08:55 PM | GPUGRID | Scheduler request completed: got 0 new tasks
11/11/2012 2:08:55 PM | GPUGRID | No tasks sent
.....
11/12/2012 9:19:50 AM | GPUGRID | Sending scheduler request: To fetch work.
11/12/2012 9:19:50 AM | GPUGRID | Requesting new tasks for NVIDIA
11/12/2012 9:19:52 AM | GPUGRID | Scheduler request completed: got 0 new tasks
11/12/2012 9:19:52 AM | GPUGRID | No tasks sent


Turn on sched_op_debug. What displays under application details for your host? (On the website, select the machine, click the details link).

I presume you don't have a silly cache size like further up in this message thread. Anything more than 7 days isn't going to work here.

____________
BOINC blog

Jacob Klein
Send message
Joined: 11 Oct 08
Posts: 1115
Credit: 1,831,665,089
RAC: 312,617
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 27306 - Posted: 14 Nov 2012 | 17:52:49 UTC - in response to Message 27300.

The issue resolved itself (which is a good thing, but also bad, because I won't be able to see what the sched_op_debug messages were.) I'll remember to do that next time, if the issue shows up again.

Also, I had been running cache settings of 0.1/0.1, but I saw your settings of 0.01/0.1 (which make even more sense to use on an always-on-always-connected computer)... so I have since switched to your 0.01/0.1 settings. Thanks for that idea.

Jhonatan Silva*
Send message
Joined: 15 May 13
Posts: 2
Credit: 1,782
RAC: 0
Level

Scientific publications
wat
Message 37399 - Posted: 24 Jul 2014 | 22:39:40 UTC

I'm having the same problem here. 2 days searching for a solution, and nothing

Jacob Klein
Send message
Joined: 11 Oct 08
Posts: 1115
Credit: 1,831,665,089
RAC: 312,617
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 37400 - Posted: 24 Jul 2014 | 23:05:43 UTC - in response to Message 37399.
Last modified: 24 Jul 2014 | 23:05:59 UTC

Jhonatan:

That request shows that it was requesting for CPU only, and not for NVIDIA.
Per the server status page, there are currently no tasks available for the "CPU Only app" application.
See: http://www.gpugrid.net/server_status.php

So, that server request, and server response, all looks correct to me.

Regards,
Jacob

Jhonatan Silva*
Send message
Joined: 15 May 13
Posts: 2
Credit: 1,782
RAC: 0
Level

Scientific publications
wat
Message 37401 - Posted: 24 Jul 2014 | 23:50:55 UTC

Thanks!

Post to thread

Message boards : Server and website : no tasks sent BOINC manager issue